Connect to BBB from OpenBSD
Take a look at BBB docs.
Connect provided USB cable to OpenBSD usb port. Its preinstalled Linux should boot up ...
Check what is provided through dmesg
dmesg
urndis0 at uhub0 port 2 configuration 1 interface 0 "BeagleBoard.org BeagleBoneBlack" rev 2.00/4.04 addr 3
urndis0: using Vendor, address b8:94:d9:b8:05:5a
umass0 at uhub0 port 2 configuration 1 interface 2 "BeagleBoard.org BeagleBoneBlack" rev 2.00/4.04 addr 3
umass0: using SCSI over Bulk-Only
scsibus4 at umass0: 2 targets, initiator 0
sd1 at scsibus4 targ 1 lun 0: <Linux, File-Stor Gadget, 0414> removable serial.1d6b01042327BBBG0251
sd1: 18MB, 512 bytes/sector, 36864 sectors
cdce0 at uhub0 port 2 configuration 1 interface 3 "BeagleBoard.org BeagleBoneBlack" rev 2.00/4.04 addr 3
cdce0: address fe:e1:ba:d0:11:0d
umodem0 at uhub0 port 2 configuration 1 interface 5 "BeagleBoard.org BeagleBoneBlack" rev 2.00/4.04 addr 3
umodem0: data interface 6, has no CM over data, has no break
umodem0: status change notification available
ucom0 at umodem0
sd1(umass0:1:0): Check Condition (error 0x70) on opcode 0x2a
SENSE KEY: Write Protected
ASC/ASCQ: Write Protected
sd1(umass0:1:0): Check Condition (error 0x70) on opcode 0x2a
SENSE KEY: Write Protected
ASC/ASCQ: Write Protected
Check cdce
man page
The cdce driver provides support for USB Host-to-Host (aka USB-to-USB)
bridges based on the USB Communication Device Class (CDC) and Ethernet
subclass
First connect network
doas ifconfig cdce0 inet 192.168.6.1 255.255.255.0
You may SSH to the machine with. Linux may also get 192.168.7.2
ssh debian@192.168.6.2
# pw: temppwd
In some way the bone have 192.168.6.1 so you only need to specify IP on your side. How to know what a suitable IP is over cdce
is unclear.
Then connect to USB mass storage device
disklabel -h /dev/sd1c
doas mount /dev/sd1i /mnt/usbdisk/
Open START.htm
for start instructions. But this does not work through regular browser on OpenBSD for some reason. Possibly because of access rights to mounted file system.
On macOS
When connected over UWB USB mass storage will be attached automatically.
You should start by opening file:
file:///Volumes/BEAGLEBONE/START.htm#step2
When connected over USB your computer will get IP 192.168.6.1 and the bone will get 192.168.6.2.
You may SSH to the machine with
ssh debian@192.168.6.2
# pw: temppwd
You may open a web browser to the machine (chrome)
http://192.168.6.2
You may open a web browser to the machine (chrome)
http://beaglebone.local./
Upgrade from macOS
Follow this guide
Create bootable SDCARD.
diskutil list
diskutil unmount /dev/disk6s1
sudo dd if=./am57xx-debian-11.6-minimal-armhf-2023-04-06-2gb.img of=/dev/rdisk6 bs=1m
Flash eMMC ...
sudo enable-beagle-flasher
Install ruby
$ uname -a
Linux BeagleBone 5.10.162-ti-r58 #1bullseye SMP PREEMPT Sat Feb 25 19:31:31 UTC 2023 armv7l GNU/Linux
Upgrade with Ethernet connected
sudo apt update
sudo apt upgrade -y
Install ruby serial support gem
sudo apt install ruby
sudo apt install ruby-dev
sudo apt install gmake
sudo apt install make
sudo gem install ffi
sudo gem install serialport